Skip to main content

4 Messages

 • 

204 Points

Mon, Sep 17, 2018 11:24 PM

Submission Issues

I keep trying to submit corrections, and I keep getting a page that states "By the action of sending information to the Internet Movie Database (IMDb) via this form, you declare that the submitted data is correct to the best of your knowledge, not copyrighted by a third party and you hereby give the IMDb permission to use it." It has a blue Continue >> button. When clicked on, I am taken back to the initial edit page where you select which categories to update or add to.

This has been happening to me on and off for the past two days. It is very time-consuming to correct the credits to start with, but to have keep correcting them and having this message pop up over and over is frustrating beyond belief.

Please, please fix this!!!

Responses

9 Messages

 • 

388 Points

2 years ago

I'm having the same problem just starting tonight, though.

Champion

 • 

1.7K Messages

 • 

55.6K Points

2 years ago

It seems to have started for me about an hour ago. Occasionally, the update gets accepted. Hopefully, an employee will chime in with a status.

Champion

 • 

1.7K Messages

 • 

55.6K Points

2 years ago

This reply was created from a merged topic originally titled Is anyone else having trouble submitting updates?.

I guess this started about an hour ago when I tried to add the last episode for Killjoys Season 4. Instead of getting a confirmation page, I get this:


It seems to be intermittent. I resubmitted the additional of episode 4.10 of Killjoys and that went through. I switched tabs and tried to submit my update of episode 4.9 and I get this. There couldn't have been more than 30 seconds between the two.

7 Messages

 • 

278 Points

2 years ago

This is happening to me as well - but only for trying to submit Locations. I've been able to submit Triva, Goofs and Images without any problem. I submitted ten carefully researched locations for a film and this happened. I then tried to submit only five and the same thing. Very frustrating.

Champion

 • 

1.7K Messages

 • 

55.6K Points

2 years ago

I was just able to submit an update that hadn't been going through.

9 Messages

 • 

388 Points

2 years ago

It's working for me now.

5.6K Messages

 • 

144.7K Points

2 years ago

This happens from time to time.

Employee

 • 

8.6K Messages

 • 

222.3K Points

2 years ago

Hi All -

The Update form should be working as normal now, if you are still experiencing problems submitting data today, please let us know the details of what data you are submitting and what error is still occurring and our staff can investigate further.